MikroTik/RouerOS/RouterBOARD

   Updated: 2021-11-28 21:21       MikroTik/RouerOS/RouterBOARD无评论

MikroTik

MikroTik 是一家位于拉脱维亚的网络设备制造商。该公司开发和销售有线和无线网络路由器、网络交换机、接入点以及操作系统和辅助软件。该公司成立于 1996 年,1997 年推出 RouterOS 系统,2002 年推出 RouterBOARD。

RouerOS

RouterOS 是 MikroTik 基于 Linux 开发的独立路由操作系统,支持大部分主流的网络协议和网络功能,并具备操作系统的特性,是 MikroTik 的主要产品。可安装在 MikroTik 公司的 RouterBoard 网络设备上或安装于标准的 x86 平台。可以认为 RouterOS 与 Android 一样,只是 RouterOS 平台是封闭的,App(应用功能包)由 MikroTik 独立开发。MikroTik 为 RouterOS 提供 nkp 的功能包,根据需要选择自己需要的功能进行安装或卸载。

RouterOS 下载页面有 4 个通道可选:

  • Long term:长期支持版本,兼容性最好。
  • Stable:稳定版,新功能稳定版本。
  • Testing:测试版。
  • Development:开发版。

稳定性由高 → 低,一般建议 Long term 版本。

RouterBOARD

RouterBOARD 是 MikroTik 基于 MIPS、PPC 和 Tilera 等平台开发的硬件,使用的是基于 Linux 内核开发的 RouterOS 系统。就如 Cisco 的路由器使用的是 IOS,基于 Unix 开发;Juniper 使用的是 JunOS,基于 FreeBSD 开发。

后期 MikroTik 又开发了两款新品,一个是基于 Tilera 构架的 Core Cloud Router(CCR 系列),另一个是基于 MIPS 构架的 Cloud Router Switch(CRS 系列)。CCR 基于高端路由,CRS 基于路由交换。

延伸阅读:RouterBOARD 产品命名与标识

相关网站

RouterOS 的常用设置

假设使用 RouterOS 拨号上网,用于拨号的 WAN 接口名称为 pppoe-out1,LAN 接口名称为 bridge

启用 Fasttrack

启用 Fasttrack 后,可以极大的减少 RouterOS 的 CPU 使用率以及带宽!注意:如果开启了 Fasttrack,simple queue 将失效。

/ip firewall filter add chain=forward action=fasttrack-connection connection-state=established,related
/ip firewall filter add chain=forward action=accept connection-state=established,related

参考:https://wiki.mikrotik.com/wiki/Manual:IP/Fasttrack

开启 UPnP

ip upnp set enabled=yes
ip upnp set allow-disable-external-interface=yes
ip upnp set show-dummy-rule=yes
ip upnp interfaces add interface=pppoe-out1 type=external
ip upnp interfaces add interface=bridge type=internal

开启 UPnP 后,会自动映射端口,所有生成的端口映射可以在 IP → Firewall → NAT 中查询,但由于 UPnP 自动生成的端口映射没有老化时间,开启 UPnP 一段时间后,NAT 列表中会存在很多记录,可以手动进行删除,或使用脚本进行删除。

图形界面设置参考:RouterOS(ROS) 软路由开启 UPNP 设置

开启 NAT1(FullCone NAT)

首先将需要 NAT1 功能的内网设备设为静态 IP(动态 IP 不行),假设静态 IP 地址为 192.168.88.11(只能设置 1 台设备,设置多台的话,只有第一台能访问外网)。

ip firewall nat add chain=dstnat in-interface=pppoe-out1 action=dst-nat to-address=192.168.88.11

图形界面设置参考:RouterOS 实现 NAT1 FullCone

RouterOS 下挂京东云的设置

假如有多台京东云路由宝。按照下面设置好后,如果您的宽带网络满足条件的情况下,所有京东云的 NAT 类型都应该变为 NAT1。网上大部分教程或论坛里都说只需要开启 RouterOS 的 UPnP 就可以,但我测试只开启 UPnP 的话,NAT 类型为 NAT3。

  1. RouterOS 拨号,并开启 UPnP 和 NAT1
  2. 找其中一台性能最好的京东云(假设叫京东云 A),开启它的 UPnP、设置模式为 NAT1、设置其外网端口为静态 IP,例如为 192.168.88.11
  3. 京东云 A 的 WAN 口插 RouterOS 的 LAN 口,其他京东云下挂到 A 下面
  4. 其他京东云设置外网端口为动态 IP,并关闭 UPnP 和 NAT1

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注